const regex = /^.*reddit\.com\/?(?!(?:message|comments)\/).*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*reddit\\.com\\\/?(?!(?:message|comments)\\\/).*?$', 'gm')
const str = `https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/
https://www.reddit.com/message/inbox/
https://www.reddit.com/r/allcomments/asdf
https://www.reddit.com/r/MechanicalKeyboards
https://www.reddit.com/r/MechanicalKeyboards/
https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}