use strict;
my $str = 'https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/
https://www.reddit.com/message/inbox/
https://www.reddit.com/r/allcomments/asdf
https://www.reddit.com/r/MechanicalKeyboards
https://www.reddit.com/r/MechanicalKeyboards/
https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s';
my $regex = qr/^.*reddit\.com\/?(?!(?:message|comments)\/).*?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}