#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*reddit\.com\/?(?!(?:message|comments)\/).*?$"
Local $sString = "https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/" & @CRLF & _
"https://www.reddit.com/message/inbox/" & @CRLF & _
"https://www.reddit.com/r/allcomments/asdf" & @CRLF & _
"https://www.reddit.com/r/MechanicalKeyboards" & @CRLF & _
"https://www.reddit.com/r/MechanicalKeyboards/" & @CRLF & _
"https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")