import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*reddit\\.com\\/?(?!(?:message|comments)\\/).*?$";
final String string = "https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/\n"
+ "https://www.reddit.com/message/inbox/\n"
+ "https://www.reddit.com/r/allcomments/asdf\n"
+ "https://www.reddit.com/r/MechanicalKeyboards\n"
+ "https://www.reddit.com/r/MechanicalKeyboards/\n"
+ "https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}