// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a href="([^"
]*)">([^<]*)<.*"#).unwrap();
let string = "<a href=\"http://coffee.stackexchange.com/users/179/mooz\">Mooz</a>";
let substitution = "[$2]($1)";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}