package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="([^"
]*)">([^<]*)<.*`)
var str = []byte(`<a href="http://coffee.stackexchange.com/users/179/mooz">Mooz</a>`)
var substitution = []byte("[$2]($1)")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}