const regex = /<a href="([^"
]*)">([^<]*)<.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="([^"
]*)">([^<]*)<.*', '')
const str = `<a href="http://coffee.stackexchange.com/users/179/mooz">Mooz</a>`;
const subst = `[$2]($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);