import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"([^\"\n"
+ "]*)\">([^<]*)<.*";
final String string = "<a href=\"http://coffee.stackexchange.com/users/179/mooz\">Mooz</a>";
final String subst = "[$2]($1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}