#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<a href="([^"" & @CRLF & _
"]*)">([^<]*)<.*"
Local $sString = "<a href="http://coffee.stackexchange.com/users/179/mooz">Mooz</a>"
Local $sSubst = "[$2]($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)