import Foundation
let pattern = #"(?<!\n\n)(^TY)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)