$re = '/(?<!\n\n)(^TY)/m';
$str = 'ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York';
$subst = "\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;