re = /(?<!\n\n)(^TY)/m
str = 'ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York'
subst = '\\n$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result