const regex = /(?<!\n\n)(^TY)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\n\\n)(^TY)', 'gm')
const str = `ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York`;
const subst = `\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);