# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\n\n)(^TY)/\n$1/gm;t' <<< "ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York"