import Foundation
let pattern = ##"([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
.test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)