import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([#.a-z]{1}[a-z_]{1}[\\s\\S]+?)\\{([\\s\\S]*?)\\}";
final String string = ".test {}\n\n"
+ "._test {\n"
+ "test: tesdff;\n"
+ "test1: tesdff;\n"
+ "test2: tesdff;\n"
+ "}\n\n"
+ "aaa {\n"
+ "test1: tesdff;\n"
+ "test2: tesdff;\n"
+ "}\n\n\n"
+ "#test {}\n\n"
+ "#test1 {}\n\n"
+ "#_test {}\n\n"
+ "#_test, \n"
+ "#test2 {}\n\n"
+ "#_test:psudo-class {}\n\n\n"
+ "#1 {}\n"
+ ".2 {}\n"
+ ".- {}\n"
+ "##test {}\n"
+ "..test {}\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}