// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}").unwrap();
let string = ".test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}