# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}/$1/g;t' <<< ".test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
"