package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}`)
var str = `.test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}