// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)!\[\[(.*_image[0-9]\.png)\]\]").unwrap();
let string = "# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}