package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!\[\[(.*_image[0-9]\.png)\]\]`)
var str = `# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}