# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"!\[\[(.*_image[0-9]\.png)\]\]"
test_str = ("# Abracadabra\n\n"
"![[Abracadabra/Abracadabra_image1.png]]\n"
"![[Abracadabra/Abracadabra_image2.png]]\n\n"
"See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.