use strict;
my $str = '# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]';
my $regex = qr/!\[\[(.*_image[0-9]\.png)\]\]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";