# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/!\[\[(.*_image[0-9]\.png)\]\]//gm;t' <<< "# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]"