// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)").unwrap();
let string = "/blog/blog-post-1234/
/blog/blog-post/xsdsf/";
let substitution = "/blog/blog-post/dsdsd/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}