#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)"
Local $sString = "/blog/blog-post-1234/" & @CRLF & _
"/blog/blog-post/xsdsf/"
Local $sSubst = "/blog/blog-post/dsdsd/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)