$re = '#^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)#m';
$str = '/blog/blog-post-1234/
/blog/blog-post/xsdsf/';
$subst = "/blog/blog-post/dsdsd/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;