using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)";
string substitution = @"/blog/blog-post/dsdsd/";
string input = @"/blog/blog-post-1234/
/blog/blog-post/xsdsf/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}