const regex = new RegExp('^/blog/([a-zA-Z]{1}[a-zA-Z0-9_/-]+)', 'gm')
const str = `/blog/blog-post-1234/
/blog/blog-post/xsdsf/`;
const subst = `/blog/blog-post/dsdsd/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);