import Foundation
let pattern = #"^https?:\/\/(?!localhost)[\.\w\d]{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
teste
http://www.outro.com.br
http://localhost
https://net.sec.org?outra=query
https://api.outro.com/?q
http://www.unsecuredapi.com
http//www
https:/www.com.br
https://regex101.com/
https://bin.com.br
http://bin.com
://teste
wss://outro
htt://mais.um.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)