re = /^https?:\/\/(?!localhost)[\.\w\d]{2,}/m
str = 'teste
http://www.outro.com.br
http://localhost
https://net.sec.org?outra=query
https://api.outro.com/?q
http://www.unsecuredapi.com
http//www
https:/www.com.br
https://regex101.com/
https://bin.com.br
http://bin.com
://teste
wss://outro
htt://mais.um.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end