import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(?!localhost)[\\.\\w\\d]{2,}";
final String string = "teste\n"
+ "http://www.outro.com.br\n"
+ "http://localhost\n"
+ "https://net.sec.org?outra=query\n"
+ "https://api.outro.com/?q\n"
+ "http://www.unsecuredapi.com\n"
+ "http//www\n"
+ "https:/www.com.br\n"
+ "https://regex101.com/\n"
+ "https://bin.com.br\n"
+ "http://bin.com\n"
+ "://teste\n"
+ "wss://outro\n"
+ "htt://mais.um.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}