use strict;
my $str = 'teste
http://www.outro.com.br
http://localhost
https://net.sec.org?outra=query
https://api.outro.com/?q
http://www.unsecuredapi.com
http//www
https:/www.com.br
https://regex101.com/
https://bin.com.br
http://bin.com
://teste
wss://outro
htt://mais.um.com';
my $regex = qr/^https?:\/\/(?!localhost)[\.\w\d]{2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}