#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(?!localhost)[\.\w\d]{2,}"
Local $sString = "teste" & @CRLF & _
"http://www.outro.com.br" & @CRLF & _
"http://localhost" & @CRLF & _
"https://net.sec.org?outra=query" & @CRLF & _
"https://api.outro.com/?q" & @CRLF & _
"http://www.unsecuredapi.com" & @CRLF & _
"http//www" & @CRLF & _
"https:/www.com.br" & @CRLF & _
"https://regex101.com/" & @CRLF & _
"https://bin.com.br" & @CRLF & _
"http://bin.com" & @CRLF & _
"://teste" & @CRLF & _
"wss://outro" & @CRLF & _
"htt://mais.um.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")