import Foundation
let pattern = #"(?<=Zeus_Web_Version = )\d.[^\s]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
d:\jenkins\workspace\ZeusWeb-Deploy>echo Zeus_Web_Version = 2.14.0.1732
Zeus_Web_Version = 2.14.0.1732
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}