import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Zeus_Web_Version = )\\d.[^\\s]+";
final String string = "\n"
+ "d:\\jenkins\\workspace\\ZeusWeb-Deploy>echo Zeus_Web_Version = 2.14.0.1732 \n"
+ "Zeus_Web_Version = 2.14.0.1732\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}