const regex = /(?<=Zeus_Web_Version = )\d.[^\s]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Zeus_Web_Version = )\\d.[^\\s]+', '')
const str = `
d:\\jenkins\\workspace\\ZeusWeb-Deploy>echo Zeus_Web_Version = 2.14.0.1732
Zeus_Web_Version = 2.14.0.1732
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}