# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+"
test_str = ("Genesis 1: 18-20\n"
"exodus 3: 15\n"
"micha\n"
"1 koningen\n"
"Johannes 4\n"
"1 Johannes 4\n"
"2 Johannes 4:15-20\n"
"psalm 150\n"
"psalm 144:2\n"
"psalmen 117\n"
"psalmen 10: 1-15\n"
"numeri 4: 1, 15-20\n"
"numeri 4: 1-5, 15-19\n"
"numeri 4: 1, 6, 15-21\n"
"numeri 4: 15 - 5:20\n"
"numeri 4:15-5:20\n\n\n\n"
"psalm 150\n"
"lied 15: 1, 2, 3\n"
"opwe 144: 1-5\n"
"144: 1-5\n"
"117\n"
"119:1,6,8-10\n"
"3:14\n\n\n"
"^([0-9]{1}[ ]?)?[a-zA-Z]+\n\n"
"((!opwekking)|(lied)|(!gez))[a-zA-Z]+")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.