use strict;
my $str = 'Genesis 1: 18-20
exodus 3: 15
micha
1 koningen
Johannes 4
1 Johannes 4
2 Johannes 4:15-20
psalm 150
psalm 144:2
psalmen 117
psalmen 10: 1-15
numeri 4: 1, 15-20
numeri 4: 1-5, 15-19
numeri 4: 1, 6, 15-21
numeri 4: 15 - 5:20
numeri 4:15-5:20
psalm 150
lied 15: 1, 2, 3
opwe 144: 1-5
144: 1-5
117
119:1,6,8-10
3:14
^([0-9]{1}[ ]?)?[a-zA-Z]+
((!opwekking)|(lied)|(!gez))[a-zA-Z]+';
my $regex = qr/^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}