$re = '/^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+/m';
$str = 'Genesis 1: 18-20
exodus 3: 15
micha
1 koningen
Johannes 4
1 Johannes 4
2 Johannes 4:15-20
psalm 150
psalm 144:2
psalmen 117
psalmen 10: 1-15
numeri 4: 1, 15-20
numeri 4: 1-5, 15-19
numeri 4: 1, 6, 15-21
numeri 4: 15 - 5:20
numeri 4:15-5:20
psalm 150
lied 15: 1, 2, 3
opwe 144: 1-5
144: 1-5
117
119:1,6,8-10
3:14
^([0-9]{1}[ ]?)?[a-zA-Z]+
((!opwekking)|(lied)|(!gez))[a-zA-Z]+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);