import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+";
final String string = "Genesis 1: 18-20\n"
+ "exodus 3: 15\n"
+ "micha\n"
+ "1 koningen\n"
+ "Johannes 4\n"
+ "1 Johannes 4\n"
+ "2 Johannes 4:15-20\n"
+ "psalm 150\n"
+ "psalm 144:2\n"
+ "psalmen 117\n"
+ "psalmen 10: 1-15\n"
+ "numeri 4: 1, 15-20\n"
+ "numeri 4: 1-5, 15-19\n"
+ "numeri 4: 1, 6, 15-21\n"
+ "numeri 4: 15 - 5:20\n"
+ "numeri 4:15-5:20\n\n\n\n"
+ "psalm 150\n"
+ "lied 15: 1, 2, 3\n"
+ "opwe 144: 1-5\n"
+ "144: 1-5\n"
+ "117\n"
+ "119:1,6,8-10\n"
+ "3:14\n\n\n"
+ "^([0-9]{1}[ ]?)?[a-zA-Z]+\n\n"
+ "((!opwekking)|(lied)|(!gez))[a-zA-Z]+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}