#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+"
Local $sString = "Genesis 1: 18-20" & @CRLF & _
"exodus 3: 15" & @CRLF & _
"micha" & @CRLF & _
"1 koningen" & @CRLF & _
"Johannes 4" & @CRLF & _
"1 Johannes 4" & @CRLF & _
"2 Johannes 4:15-20" & @CRLF & _
"psalm 150" & @CRLF & _
"psalm 144:2" & @CRLF & _
"psalmen 117" & @CRLF & _
"psalmen 10: 1-15" & @CRLF & _
"numeri 4: 1, 15-20" & @CRLF & _
"numeri 4: 1-5, 15-19" & @CRLF & _
"numeri 4: 1, 6, 15-21" & @CRLF & _
"numeri 4: 15 - 5:20" & @CRLF & _
"numeri 4:15-5:20" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"psalm 150" & @CRLF & _
"lied 15: 1, 2, 3" & @CRLF & _
"opwe 144: 1-5" & @CRLF & _
"144: 1-5" & @CRLF & _
"117" & @CRLF & _
"119:1,6,8-10" & @CRLF & _
"3:14" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([0-9]{1}[ ]?)?[a-zA-Z]+" & @CRLF & _
"" & @CRLF & _
"((!opwekking)|(lied)|(!gez))[a-zA-Z]+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")