$re = '/<a.*\shref=[\"\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\"\'].*>/';
$str = '<a href="http://www.pochta.ru">Почта</a>
<a href="http://top100.rambler.ru/top100/All/rate21.0.shtml.ru"><img src="http://pics.rbc.ru/img/ver99/counter_rambler.gif" alt="Rambler\'s Top100 Service" width=88 height=31 border=0></a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);