import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*\\shref=[\\\"\\'](?:(?:\\w+)://)*((?:[\\w-]+\\.)+(?:[\\w-]+))(?::\\d+)?(?:/|$)?(?:[^\\s]+)?[\\\"\\'].*>";
final String string = "<a href=\"http://www.pochta.ru\">Почта</a>\n"
+ "<a href=\"http://top100.rambler.ru/top100/All/rate21.0.shtml.ru\"><img src=\"http://pics.rbc.ru/img/ver99/counter_rambler.gif\" alt=\"Rambler's Top100 Service\" width=88 height=31 border=0></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}