use strict;
my $str = '<a href="http://www.pochta.ru">Почта</a>
<a href="http://top100.rambler.ru/top100/All/rate21.0.shtml.ru"><img src="http://pics.rbc.ru/img/ver99/counter_rambler.gif" alt="Rambler\'s Top100 Service" width=88 height=31 border=0></a>';
my $regex = qr/<a.*\shref=[\"\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\"\'].*>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}