using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*\shref=[\""\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\""\'].*>";
string input = @"<a href=""http://www.pochta.ru"">Почта</a>
<a href=""http://top100.rambler.ru/top100/All/rate21.0.shtml.ru""><img src=""http://pics.rbc.ru/img/ver99/counter_rambler.gif"" alt=""Rambler's Top100 Service"" width=88 height=31 border=0></a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}