#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*\shref=[\"\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\"\'].*>"
Local $sString = "<a href="http://www.pochta.ru">Почта</a>" & @CRLF & _
"<a href="http://top100.rambler.ru/top100/All/rate21.0.shtml.ru"><img src="http://pics.rbc.ru/img/ver99/counter_rambler.gif" alt="Rambler's Top100 Service" width=88 height=31 border=0></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")