import Foundation
let pattern = #"\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// YES
WFTDOC_TASK_DOCUMENT_V01
WFTASK_TASK_V01
// NO
[WFW].[WFLOW_WORKFLOW_V01]
WFW.WFTASK_TASK_V01
Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01
WORKER_TOKEN_NR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)