using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b";
string input = @"// YES
WFTDOC_TASK_DOCUMENT_V01
WFTASK_TASK_V01
// NO
[WFW].[WFLOW_WORKFLOW_V01]
WFW.WFTASK_TASK_V01
Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01
WORKER_TOKEN_NR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}