$re = '/\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b/';
$str = '// YES
WFTDOC_TASK_DOCUMENT_V01
WFTASK_TASK_V01
// NO
[WFW].[WFLOW_WORKFLOW_V01]
WFW.WFTASK_TASK_V01
Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01
WORKER_TOKEN_NR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);